Snowblower Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hello everyone. I have a ST1032 that's in pretty nice shape. I have had it 5 or 6 years now and its been a great machine. I do have 1 issue though. The discharge chute like to rattle around and in general is kinda loose fitting. What can I do to resolve this? do they make shims or anything for it? Doesn't seem to be affecting performance but its just annoying because the rattle is quite loud at idle etc. Thanks
 

·
Registered
Joined
·
208 Posts
I find putting some low temperature grease around the mounting ring that the chute rotates on will often get rid of the rattle. You should also make sure all the hardware that secures the chute is straight and tight.
 

·
Registered
Joined
·
2,310 Posts
If you need a shim, why not use washers?
 

·
Premium Member
Joined
·
463 Posts
GEvening WM, I just serviced one of those units tonight. As suggested, I removed the chute to line that ring with grease. It does help with noise and movement. I also tighten up the 9/16" nut on the chute pivot bolt. Keeps the chute solid and prevents it whipping as the snow flies thru it.

GLuck, Jay
 

·
Registered
Joined
·
1,288 Posts
my 924050 does it as well it drives me batchit
guess ill try grease dont think it will work it might help
should just put the tall chute on it and call it a day
 

·
Registered
Joined
·
1,288 Posts
just checked i all ready have the tall 18.5 chute dont think you can get a taller one without reworking it
 

·
Registered
Joined
·
1,288 Posts
took chute off cleaned up all the crud re greased with the extra 00 ariens grease quite as mouse now works smoothly
 
1 - 10 of 10 Posts
Top