Snowblower Forum banner

1 - 3 of 3 Posts

·
Banned
Joined
·
1 Posts
Discussion Starter #1
Hi,

Need help diagnosing and fixing this problem I have.

Bought a Toro Powerclear 721 qze couple months back. I have used it probably less than 10 times and without a hitch until just recently.

Now when I fully (and slowly) disengage the choke lever, the engine cuts out. This is after the recommended prep: push primer 3x, fully engage the choke lever, pull on the recoil handle.

If I move the lever so that it is half-choke, it still runs.

The only thing I can think of is my old gas can might have introduced gunk and debris into the carburetor or something during refill. I don't think I've ever cleaned the gas can since it was purchased many years back.
 

·
Registered
Joined
·
126 Posts
Agree you have a dirty carb. These newer Toro SS are PIA to get the carb off. If you are patient and lucky to some extent, you can get the main jet and emulsion tube out with carb still on. Tilt it up, so you can see the bottom of carb, clamp off the fuel line and pull the bowl. Look up in the center and remove the slotted main jet (use a round shafted screwdriver or bit that fits without hitting threads). If you're lucky the jet AND emulsion tube will fall out. On those Loncin engines it's been my experience the jet will often come out, but the emulsion tube will hang on. You may need to get a lever inside the carb and knock the emulsion tube down. Not much room, and you don't want to blindly go digging around. Loncin carbs still have a brass emulsion tube and the tiny holes on the side being plugged up or green are almost always the problem given your symptoms. If the main jet itself was plugged it wouldn't start.
 
1 - 3 of 3 Posts
Top