Snowblower Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Picked up an old CCR2000 for $25. It wouldn't start and I determined that it wasn't getting fuel. I put in a new carb, new fuel line and new fuel filter (and fresh gas). Starts right up now, but it's surging and will occasionally shut down after about 10 minutes. Any ideas? Thanks!
 

·
Registered
Joined
·
772 Posts
Picked up an old CCR2000 for $25. It wouldn't start and I determined that it wasn't getting fuel. I put in a new carb, new fuel line and new fuel filter (and fresh gas). Starts right up now, but it's surging and will occasionally shut down after about 10 minutes. Any ideas? Thanks!
the surging wouldnt be the ignition its a lean condition but the shutting down would definitely be the coil once it heats up they tend to fail.

might be cheaper to find another one and pick it up for cheap and steal the oem carb and ignition. would me less expensive than trying to buy the individual parts.
 

·
Registered
Joined
·
2,315 Posts
Would an ignition module such as Mega Fire or Nova solve the ignition problem?
 

·
Registered
Joined
·
772 Posts
Would an ignition module such as Mega Fire or Nova solve the ignition problem?
some people have had luck with them i have never had an ignition problem with any of the 2000's that i have had.

so i dont have any experience with them.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #8
**UPDATE**
I picked up a Mega Fire ignition module...installed it and she fired right up. Unfortunately, 5 or so minutes later, she started revving and died. Same as before. Now I'm wondering if there is a fuel delivery problem. Feels like she is running until the fuel in the bowl is spent. When this happens, a couple pumps to the primer and it fires right up again.


Keep in mind, I installed a new (after-market) carb, new fuel filter and fuel line. Then I thought maybe the gas cap was clogged. But, it did the same thing with the cap off.


I'm a little stumped here and hoping you wise snowblower gurus might have a suggestion? Thanks
 

·
Registered
Joined
·
9 Posts
Discussion Starter #10
Yes, starting to realize that. Fortunately, I don't have a lot into it. It's turning into a challenge at this point and just can't figure out what it could be.
 

·
Registered
Joined
·
772 Posts
Yes, starting to realize that. Fortunately, I don't have a lot into it. It's turning into a challenge at this point and just can't figure out what it could be.
i have never used an aftermarket carb on the sizuki 2000's i have had i always clean and rebuilt the mikuni carburetor Suzuki's seem to be picky below is a guy that had to modify a brand new aftermarket carb to get it to work.

it seems like a fuel problem was the oem carb beyond repair?


http://www.snowblowerforum.com/forum/toro-snowblowers/117193-ccr-2000-carb-tuning-issues.html
 

·
Registered
Joined
·
117 Posts
Possible the vent on the gas cap is broken/plugged? If it runs for 10 min then shuts down it could be. The fuller the tank the sooner the problem will crop up.
 
1 - 13 of 13 Posts
Top