Snowblower Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Just bought the Toro PowerClear 180 w/electric start. After running the PowerClear 180 I noticed the exhaust smell is strong. Is this normal?
 

·
Registered
Joined
·
143 Posts
Just bought the Toro PowerClear 180 w/electric start. After running the PowerClear 180 I noticed the exhaust smell is strong. Is this normal?
Probably.
Chances are what you are smelling is the paint and any other products on the engine that more or less "burn" off during the first few times you use the machine.
My new Toro PowerClear 421 had an odor the first time I used it.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Probably.
Chances are what you are smelling is the paint and any other products on the engine that more or less "burn" off during the first few times you use the machine.
My new Toro PowerClear 421 had an odor the first time I used it.
was it an exhaust odor that stuck to your clothes?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
While it might be, it won't be the 2 cycle odor that sometimes occurs.
The Toro 180 has a 4 cycle engine.

And if that is not what you had in mind, my apologies. :)
Its the 4 cycle engine. You do not mix oil with gas in this one.

So its nothing to be worried about?
 

·
Registered
Joined
·
143 Posts
Its the 4 cycle engine. You do not mix oil with gas in this one.

So its nothing to be worried about?
Probably not.
Check the engine oil level and if it is OK, you probably don't have anything to worry about.
Mine had what I would call a hot smell after the first use, but I didn't notice it the second time I used it.
 

·
Premium Member
Joined
·
310 Posts
Probably.
Chances are what you are smelling is the paint and any other products on the engine that more or less "burn" off during the first few times you use the machine.
My new Toro PowerClear 421 had an odor the first time I used it.
Ditto, it isn't unlikely for a new snowblower like that to give off some bad fumes for the first several minutes of runtime. How long have you had it runing yet? My guess is that if this is reason for the smell ,it should be gone after a while.
 
1 - 10 of 10 Posts
Top